Primus Omnifuel Ergopump repair

5:52 p.m. on September 22, 2009 (EDT)
0 reviewer rep
1 forum posts

Hi there,

I have a problem with my stove that I have not been able to solve, neither find anything useful in the Internet:

After making the mistake of trying to use gas designed for car use in my Primus Omnifuel, I decided to clean it thoroughly, including the pump. What happens now is that when trying with white gas, the stove leaks fuel at the top of the pump and I can't get pressure. I've tried to put apart the pump and the leather piece seems to be in good condition, but no results again ... And here is where I am stuck. Could anybody help me, guys ?

Thanks a lot in advance

Javier

8:41 p.m. on September 22, 2009 (EDT)
0 reviewer rep
223 forum posts

It sounds to me like the NRV(non return valve) at the bottom of the pump tube(where the air comes out) is stuck open or broken. Try looking at it first to see if there's a piece of debris in it. You may have to remove and disassemble it.

5:53 p.m. on October 2, 2009 (EDT)
107 reviewer rep
32 forum posts

After making the mistake of trying to use gas designed for car use in my Primus Omnifuel,

Any particular reason this was a mistake? I use car fuel pretty often for my omnifuel, when I run out of white gas/propane. Haven't had any problems with it yet.

September 30, 2014
Quick Reply

Please sign in to reply

 
More Topics
This forum: Older: Taking care of your tent Newer: Patching mesh on a tent
All forums: Older: Garmont Syncro Plus gtx Newer: FS - Medium Blue RTG Jacket with tracks