About | Blog | Forums | People | Free Newsletter
Trailspace is a product review site for outdoor enthusiasts. Use it to find and share great gear.

database error while posting

2:08 p.m. on November 20, 2010 (EST)
TOP 25 REVIEWER REVIEW CORPS
1,018 reviewer rep
1,208 forum posts

I'm not complaining, just thought you'd want to know about this.  I got this error just now while trying to post. 

An Error Was Encountered

Error Number: 1062

Duplicate entry '81047-41734' for key 1

INSERT INTO forum_post_asset (post_id, asset_id) VALUES ('81047','41734')

 

I did a refresh and it posted correctly.

If it matters, I had made a post in which I inserted a photo (I uploaded it as a "new upload" while posting the message).  Then I noticed a change i wanted to make in the photo (it was over-sharpened) so I edited the message and again re-uploaded the new image during the message edit.  When I said "post message" there was a "long" delay then the db error.

This is the message:

http://www.trailspace.com/forums/beginners/topics/80801.html#81047

And as a true "user" (in IT lingo) I got impatient during the "long delay" and did a browser "stop" followed by a page refresh, so maybe I brought it on myself (but still the app shouldn't error out)...

 

7:59 p.m. on November 20, 2010 (EST)
TRAILSPACE STAFF
234 reviewer rep
924 forum posts

Thanks Bill. I'm embarrassed that you (or anyone) saw that. You're right that we should be catching and handling that sort of error much more gracefully. Thank you for the thorough bug report -- that will be very helpful for tracking it down and fix the problem.

Anybody else had a problem similar to this when posting images?

8:06 p.m. on November 20, 2010 (EST)
TOP 25 REVIEWER REVIEW CORPS
1,018 reviewer rep
1,208 forum posts

Thanks Dave - nothing to be embarrassed about - it's software!  :)

 

10:08 a.m. on November 22, 2010 (EST)
MODERATOR REVIEW CORPS
658 reviewer rep
2,137 forum posts

I have another odd glitch that happens from time to time:

When posting a reply to an existing thread, upon clicking "post reply" the browser navigates tof the "start a new topic" page instead of posting the reply. I am not at all certain why this happens, but I have started using "Ctrl+C" on my text before clicking "post" so I don't lose my message. It doesn't happen all the time, but enough that I take that precautionary step.

I recognize also that it may be a result of our network security protocals causing some error, as they are pretty stringent.

(user details: Win XP pro, IE8)

3:57 p.m. on November 22, 2010 (EST)
TRAILSPACE STAFF
234 reviewer rep
924 forum posts

Thanks, Gonzan. That sounds like a major bug.

Since this seems to be happening to you fairly regularly, the next time it happens could you let me know: what thread you were replying to, and the URL displayed in your browser's address bar when you see the "new topic" page?

Thanks
-Dave

 

4:22 p.m. on November 22, 2010 (EST)
MODERATOR REVIEW CORPS
658 reviewer rep
2,137 forum posts

Sure. I think maybe it's happened five or six times in the last month or two. With my luck iIt will probably not do it again and make a liar of me :) 

12:35 p.m. on December 14, 2010 (EST)
MODERATOR REVIEW CORPS
658 reviewer rep
2,137 forum posts

Hey Dave, that glitch I mentioned earlier happened again, of a "new thread" window opening when I click "post reply" while attempting to comment to an existing thread.

>The thread I was attempting to reply to was "There's an App for That" in the Feedback forum.

>The page that opened was "Start a New Topic in Feedback"

>The URL in the adress bar of the new topic page which opened is: http://www.trailspace.com/forums/feedback/post.html  

Upon navigating back and attempting to reply a second time, it worked fine.

Thanks Dave!

10:11 p.m. on December 15, 2010 (EST)
TRAILSPACE STAFF
234 reviewer rep
924 forum posts

Thanks, Gonzan. I'm not sure why you're getting that intermittently, but this gives me a couple areas to investigate.

Anyone else who has experienced this problem: could you please post to this thread or send me an email? Thanks!

10:25 p.m. on December 15, 2010 (EST)
MODERATOR REVIEW CORPS
658 reviewer rep
2,137 forum posts

Sure thing, Dave. I will let you know if it happens again. Your hard work is appreciated!

April 19, 2014
Quick Reply

Please sign in to reply

 
More Topics
This forum: Older: Commits on pictures Newer: Replies to posts
All forums: Older: Warm December to hike the Grand Canyon Newer: Tent Choices -- HELP!