Primus Omnifuela problem

2:08 a.m. on June 9, 2012 (EDT)
0 reviewer rep
3 forum posts

Hi!

I hope someone can help me.

I use Primus Omnifuel every day for a year (on a long bicycle tour). Now it stopped to  workI cleaned all parts, but diesel does not come through the line. The line is not clogged. I took out the filter from the line and tried to air it passes - and it works. However, the diesel does not come when I put the filter back.
When a bottle of lean at an angle, petrol starts to come and light the flame, but only a few seconds and then turns off.

Any advice what to do?


8:37 a.m. on June 9, 2012 (EDT)
MODERATOR REVIEW CORPS
968 reviewer rep
3,470 forum posts

Welcome to Trailspace Snezana!

We have members who know more about the Primus than I do, one of them should be able to help you.  

Does the fuel pump feel like it builds up pressure in the bottle?

When you cleaned the parts, did you also clean the jet?

Mike G.

4:26 p.m. on June 9, 2012 (EDT)
102 reviewer rep
2,280 forum posts

If you take apart the pump you will see the part you pump to build pressure, has a rubber or leather thing on the other end.  That thing is what trps the air you pump to build pressure in the fuel tank, which in turn forces fuel into the line going to the stove.  Try apply cooking oil to that thing if it looks dry.  The oil will aid completing the seal between that thing and the pump's cylinder wall. 

If you still can’t get fuel to flow to the stove, The thing described above may be damaged, or the check valve in the pump damaged. Purchase a service and maintenance parts kit, and follow the instructions.

Ed

2:53 a.m. on June 13, 2012 (EDT)
0 reviewer rep
3 forum posts

Hi! Sorry because I didn't response before, but I am on the road and don't have internet often.

It's  turn out that the rubber in a pump was dry and a little oil on it solved the problem. Now, fuel passes through the line but does not spray, only drips. I guess that's the problem with the pressure in the bottle. What is the solution for this?

8:20 a.m. on June 14, 2012 (EDT)
102 reviewer rep
2,280 forum posts

Clean the hole in the burner orifice; it may be dirty or clogged.  If still insufficient fuel your pump is not generating pressure; the rubber thing you mention may be damaged.  Also inspect and clean the check valve I mentioned above.  But if you want to stop screwing around with the stove, get a maintenance kit and follow the instructions.  That usually solves whatever problem you can have.

Ed

5:08 a.m. on June 15, 2012 (EDT)
0 reviewer rep
3 forum posts

The problem was in the filter on the end of the fuel pick. I took it and now I have nothing there. Maybe I'll put a little peace of cotton. Primus work now like new

July 28, 2014
Quick Reply

Please sign in to reply

 
More Topics
This forum: Older: Tent poles Newer: MSR stove parts wanted
All forums: Older: Space Blankets Newer: DANA DESIGN ARCFLEX TERRAPLANE BACKPACK